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1 Welcome

The Telescience Resource Kit (TReK) is a suite of software applications and libraries that
can be used to monitor and control assets in space or on the ground.

The TReK HPEG application provides the capability to access the Huntsville Operations
Support Center (HOSC) Payload Ethernet Gateway (HPEG) service.

1.1 Getting Started

Start with the Introduction which provides an application overview. Next, try the Quick
Start Guides for “How Tos” for common functions. For help with details, reference the
Details section. See the FAQ and Troubleshooting section for helpful hints and solutions
to the common “gotchas”.

1.2 System Requirements
Windows 7, Red Hat Enterprise Linux 6.x.

2 Technical Support

If you are having trouble installing the TReK software or using any of the TReK software
applications, please try the following suggestions:

Read the corresponding material in the manual and/or on-line help.
Ensure that you are correctly following all instructions.

Checkout the TReK Web site at http://trek.msfc.nasa.gov/ for Frequently Asked
Questions.

If you are still unable to resolve your difficulty, please contact us for technical assistance:

TReK Help Desk E-Mail, Phone & Fax:

E-Mail: trek.help@nasa.gov
Telephone: 256-544-3521 (7:00 a.m. - 3:30 p.m. Central Time)
Fax: 256-544-9353

TReK Help Desk hours are 7:00 a.m. — 3:30 p.m. Central Time Monday through Friday.
If you call the TReK Help Desk and you get a recording please leave a message and
someone will return your call. E-mail is the preferred contact method for help. The e-
mail message is automatically forwarded to the TReK developers and helps cut the
response time.
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3 Introduction

The TReK HPEG application provides the capability to access the Huntsville Operations
Support Center (HOSC) Payload Ethernet Gateway (HPEG) service. The HPEG service
provides access to payloads onboard the International Space Station (ISS) using standard
network protocols and services. Services supported include:

Ping over ICMP

Hypertext Transfer Protocol Secure (https) over TCP on port 443
Remote Desktop (rdp) over TCP on port 3389

e Secure Shell (ssh) over TCP on port 22

e CCSDS File Delivery Protocol (CFDP) over UDP on port 4560

Note: In the event this list does not match the Payload to Generic User Interface
Definition Document (PGUIDD) SSP 50305, the information in the PGUIDD takes
precedent.

Access to these services is based on HOSC account privileges.
The general sequence of events when using HPEG is as follows:

Establish VPN session with HOSC.

Start the TReK HPEG application.

Push the Configure button to configure the application.

Push the Activate button to activate the HPEG service.

During activation you will be prompted to log into your HOSC account.

Once the HPEG service is active, start a session with your destination (payload).
Use the Proxy IP address returned to communicate with your payload using other
products such as the TReK CFDP application, Remote Desktop, a console command
line to ssh, etc.

e When finished Deactivate and Exit.

Interfaces between TReK and the HOSC are shown in Figure 1. An initial interface is
established to login and a second interface is established for HPEG communication
(starting and stopping sessions, etc.).

Huntsville Operations POIC Login using ERIS TRek HPEG
Support Center (HOSC) - = Application
Payload Operations (trek_hpeg]
Integration Center . HPEG Communication -
(POIC) B -

Figure 1 TReK/POIC Communication
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Figure 2 shows the standard IP communication that is possible between ground
applications and flight applications once HPEG services have been started.

1S5 Payload Ground Application
Application . Standard IP Protocols PP
Onboard 155 B - (ssh, ping, etc.)

Figure 2 Standard IP Communication

4 Overview of the User Interface

4.1 Main Window

The main window is shown in Figure 3. The Message area is a dock window that you
can float or dock. To float a dock window, use your left mouse button to click and hold
the title area while dragging the window to another area of the screen. To dock, use the
title bar to drag the dock window over the main window and drop.

lEiIe View HPEG Options Help

Configuration: . Operational . Activate Deactivate

HPEG User:  HPEG Commanding: Ku Forward: KuReturn: Increment:  Operational Mode:  Idle Chedk: Enable

Destination Status IP Message Space ModelD  Service Port

Start Session Stop Session

Message Area [

Figure 3 Main Window

Configuration Toolbar
The Configuration toolbar at the top of the window provides quick access to configure
the application, activate, and deactivate the HPEG service.

HPEG Toolbar

The HPEG toolbar (located under the Configuration toolbar) provides quick access to
HPEG Status and Configuration information. It also provides the capability to Enable
and Disable the HPEG Idle Check capability.
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Ground Node ID Toolbar

The Ground Node ID Toolbar (located under the HPEG toolbar when displayed) provides
quick access to the Ground Node ID. If you do not have a Ground Node ID assigned, this
toolbar will not be displayed. The Ground Node ID toolbar is only displayed when the
HPEG service is active and a Ground Node ID is in use.

HPEG

The HPEG area provides a list of “Destinations” onboard 1SS you are authorized to
access through the HPEG. Typically you will have one destination in the list — your
payload. The HPEG area also provides “Start Session” and “Stop Session” buttons to
start and stop an HPEG session for a selected destination. Once you activate the HPEG
service, and you have a destination in your list, you will be able to see the specific
services authorized for use with that destination (e.g. ping, ssh, cfdp). If you are
authorized to use the CFDP service, you will be assigned a Ground Node 1D, and your
payload onboard will be assigned a Space Node ID. These IDs correspond to CFDP
Entity IDs (EIDs) needed by the CFDP protocol. If you are authorized to use the CFDP
service, you will be prompted to select your Ground Node ID during HPEG activation. It
is possible to have more than one Ground Node ID assigned. In this case you will be
prompted with a list and can select the Ground Node ID you would like to use for the
session. If you are not authorized to use the CFDP service, you will not be prompted for
a Ground Node ID and the Space Node ID field will always be empty.

If you are authorized to use the CFDP service, you must select a Ground Node 1D when
prompted. If you select a Ground Node ID that is in use, you will be prompted again. If
all Ground Node IDs are in use, you will need to free one of the Ground Node IDs so you
can select one that is available or cancel the activation.

Message Area
The Message Area displays important information, warning and error messages. The

message area can be cleared using the View menu.

4.2 Toolbars

There are three toolbars: Configuration, HPEG and Ground Node ID. The Configuration
toolbar provides visual information about the state of the application and provides access

to common application functions. The HPEG toolbar provides HPEG Configuration and

Status information. The Ground Node ID toolbar provides access to the Ground Node 1D
selected during activation.

4.2.1 Configuration Toolbar

The Configuration toolbar is shown in Figure 4. It can be used to configure the
application, activate the HPEG service, and deactivate the HPEG service.
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Configuration: . Configure | Operational . Activate Deactivate

Figure 4 Configuration Toolbar

Configuration Status

When the Configuration status is black, this indicates the application has not been
configured. When the Configuration status is green, this indicates the application has
been configured and the HPEG service can be activated.

Use the Configure button to access the Configuration dialog to configure the application.

Operational Status

When the Operational status is black, this indicates the HPEG service is inactive. When
the Operational status is green, this indicates the HPEG service is active. The application
must be properly configured before the Activate button will be available. The HPEG
service must be active before the Deactivate button will be available.

Use the Activate button to activate the HPEG service. This will initiate all internal
activities needed to prepare the application to support the HPEG service. If you need to
reconfigure the HPEG application, deactivate the HPEG service, and then push the
Configure button to reconfigure.

4.2.2 HPEG Toolbar

The HPEG toolbar is shown in Figure 5 and Figure 6. When the HPEG service is
Inactive, the HPEG Toolbar will not contain any HPEG Status and Configuration
information. When the HPEG service is activated, the HPEG Toolbar will display HPEG
Status and Configuration information. For details about HPEG Status and Configuration
information please reference Section 6.2. The HPEG Toolbar also provides the capability
to Enable and Disable the HPEG Idle Check. This feature is only available when the
HPEG service is active.

HPEG User: HPEG Commanding:  KuForward: KuReturn: Increment:  Operational Mode:  Idle Check: Enable Disable

Figure 5 HPEG Toolbar

HPEG User: Enabled HPEG Commanding: Enabled KuForward: AOS KuReturn: LOS Increment: 41 Operational Mode: Test Idle Check: Enabled Enable Disable

Figure 6 HPEG Toolbar Populated

4.2.3 Ground Node ID Toolbar

The Ground Node ID Toolbar is shown in Figure 7. This toolbar provides quick access
to the Ground Node ID. If you do not have a Ground Node ID assigned, this toolbar will
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not be displayed. The Ground Node ID toolbar is only displayed when the HPEG service
is active and a Ground Node ID is in use.

Ground Node ID: 345

Figure 7 Ground Node ID Toolbar

4.3 Menus

The HPEG application menus are: File, View, HPEG, Options, and Help. Each of these
menus is described in more detail below.

File Menu
The File menu provides the capability to exit the application.

View Menu
The View menu provides the capability to clear the main window message area and show
and hide the main window message area.

HPEG Menu
The HPEG menu provides the capability to configure the application, activate and
deactivate the HPEG service, and show HPEG messages.

Options Menu
The Options menu provides the capability to change your POIC password, re-authenticate

your POIC login, request a POIC login re-authentication status, and request POIC
common information. It also provides access to the Messages dialog which can be used
to display and filter application messages. Access to advanced settings is also available.

Help Menu
The Help menu provides access to on-line help and application version information.

5 Quick Start Guides
This section provides “How Tos” for common functions.

5.1 How to Configure the Application

The following steps describe the minimum necessary to configure the application. For
additional information and details about the Configure dialog please reference section
6.1.

1. Push the Configure button to display the Configure dialog.
2. Enter avalid local IP address.
3. Enter the POIC Host Name or POIC IP Address.
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Enter the POIC port.

Enter a port number that may be used for communication between TReK and the
HOSC about HPEG.

Push the OK button to save the configuration information and exit the dialog.

Note: If your site requires Firewall Network Address Translation, use the Firewall
(NAT) tab to enter this information.

If the application is configured correctly, the Configuration status will be green.

5.2 How to Start and Stop the HPEG Service
This section describes how to start (activate) and stop (deactivate) the HPEG service.

1.

w

Before the HPEG service can be started, you must configure the application. To learn
more about this see section 5.1. The Configure status must be green before you can
start the HPEG service.

To start the HPEG service, push the Activate button on the Configuration toolbar.
The activation process will initiate a POIC login and request the HPEG service. If
this is successful the Operational status will turn green, the HPEG toolbar will be
populated with HPEG Configuration and Status information, and you will see a list of
authorized destinations in the HPEG area.

To stop the HPEG service, push the Deactivate button.

When activating or deactivating important status and/or error messages will be
displayed in the Main Window message area.

5.3 How to Start a Session with a Destination
This section describes how to start a session with a destination.

1.
2.

The HPEG application must be configured and the HPEG service must be active.
Select an Inactive Destination in the HPEG area and push the Start Session button.
This will send a request to the POIC to start a session for the destination. If this is
successful, the destination’s Status column will show Active and the Proxy IP
Address will be displayed in the IP column. If you have a Space Node ID, it will be
shown in the Space Node ID column. You will also see a message in the Message
column indicating the status of your “Start Session” request.
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[P =)
File View HPEG Options Help

Configuration: [ Operational [l |  Activate

HPEG User: Enabled HPEG Commanding: Enabled Ku Forward: AQS KuReturn: LOS Increment: 41 Operational Mode: Flight Idle Check: Enabled Enable

Ground Node ID: 345

Destination Status 1P Message Space NodelD Service Port
» PayloadX31 Inactive 2001
|

Start Session | | Stop Session
Message Area g X

GMT 2014-08-15 16:50:30:557 Info: POIC Login Successful.

GMT 2014-08-15 16:50:30:626 Info: Accepted connection for Socket 1.2,192,168,1,51.8819.3 IP Address: 192,168.1.51 Port: 1174
GMT 2014-08-15 16:50:31:044 Info: User selected Ground Node ID 345

GMT 2014-08-15 16:50:31:053 Info: Successfully activated support for HPEG.

HPEG Active

Figure 8 Inactive Destination Selection

r- TReK HPEG

File View HPEG Options Help
Configuration: [ Operational [l |  Activate

HPEG User: Enabled HPEG Commanding: Enabled Ku Forward: AOS KuReturn: LOS Increment: 41 Operational Mode: Flight Idle Check: Enabled Enable

Ground Node ID: 345

Destination Status 1P Message Space NodelD Service Port
4 PayloadX31 Active 192168.1.25 Successfully Initialized (0): Success! 2001
ping
ssh 22
cfdp 4560

Start Session | | Stop Session
Message Area g X
GMT 2014-08-15 16:50:30:557 Info: POIC Login Successful.
GMT 2014-08-15 16:50:30:626 Info: Accepted connection for Socket 1.2,192,168,1,51.8819.3 IP Address: 192,168.1.51 Port: 1174
GMT 2014-08-15 16:50:31:044 Info: User selected Ground Node ID 345
GMT 2014-08-15 16:50:31:053 Info: Successfully activated support for HPEG.

Figure 9 Active Destination

5.4 How to Stop a Session with a Destination
This section describes how to stop a session with a destination.

1. The HPEG application must be configured and the HPEG service must be active.

2. Select an “Active” Destination in the HPEG area and push the Stop Session button.
This will send a request to the POIC to stop the session for that destination. If this is
successful, the destination’s Status column will show Inactive and the IP column will

be blank. You will also see a message in the Message column indicating the status of
your “Stop Session” request.
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5.5 How to View the Services Associated with a Destination

Click on the arrow located next to a destination to view the list of approved services
associated with a specific destination.

Wl TRek HPEG E23
File View HPEG Options Help

Configuration: Operational Activate

HPEG User: Enabled HPEG Commanding: Enabled Ku Forward: AQS KuReturn: LOS Increment: 41 Operational Mode: Flight Idle Check: Enabled Enable

Ground Node ID: 345

Destination Status 1P Message Space NedelD Service Port
4 PayloadX31 Active 1921681.25 Successfully Initialized (0): Success! 2001
ping
ssh 22
cfdp 4560
art Se: 0p Se:
Message Area g X

GMT 2014-08-15 16:50:30:557 Info: POIC Login Successful.

GMT 2014-08-15 16:50:30:626 Info: Accepted connection for Socket 1.2,192,168,1,51.8819.3 IP Address: 192,168.1.51 Port: 1174
GMT 2014-08-15 16:50:31:044 Info: User selected Ground Node ID 345

GMT 2014-08-15 16:50:31:053 Info: Successfully activated support for HPEG.

Figure 10 Destination Services List

5.6 How to Enable and Disable the HPEG Idle Check

The Enable and Disable buttons on the HPEG toolbar can be used to control the HPEG
Idle Check. If you disable the HPEG Idle check, you will not be prompted when your
HPEG session has been idle for a HOSC configuration amount of time.

5.7 How to Change Your POIC Login Password
The Options menu provides the capability to initiate a POIC password change.

5.8 How to Re-Authenticate your POIC Login
The Options menu provides the capability to initiate a POIC login re-authentication.

5.9 How to Request a POIC Login Re-Authentication Status

The Options menu provides the capability to request a POIC login re-authentication
status.
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5.10 How to Request POIC Common Information

The Options menu provides the capability to request POIC Common Information. This
includes various types of information such as project, mission, and database information.

6 Details
This section covers various application details.

6.1 Configuration

The Configure dialog contains two tabs: General and Firewall (NAT).

The General tab is used to provide information needed for TReK to communicate with
the POIC about HPEG. The Firewall (NAT) tab can be used to enter configuration
information for locations using a firewall with network address translation.

6.1.1 General Tab
The General tab is shown in Figure 11. Each field is described below.

|

2 (i
General Firewall (MAT)
Local IP Address:  127.0.0.1

POIC Information

(71 POIC Host Mame:

@ POIC IP Address:  127.0.0.1

POIC Port: 9209

HOSC Payload Ethernet Gateway (HPEG) I

Local HPEG Port: 3319

[ Ok, ] [ Cancel ]

Figure 11 Configure Dialog (General Tab)

Local IP Address
This field should contain your local IP address.

POIC Information
POIC information fields include the POIC Host Name, POIC IP Address, and POIC Port.

10
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HOSC Payload Ethernet Gateway (HPEG)
A TCP socket is created to send and receive HPEG information between TReK and the
POIC. The Local IP Address and HPEG port are used to create this TCP socket.

6.1.2 Firewall (NAT) Tab
The Firewall tab is shown in Figure 12. Each field is described below.

T ~ ™
U
m Firewall (MAT)

[] Firewall In Use {Metwork Address Translation Needed)

Firewall IF Address:

Firewall HPEG Port:  |8819

[ Ok ] [ Cancel

R —
Figure 12 Configuration Dialog (Firewall Tab)

Firewall In Use (Network Address Translation Needed)
Check the “Firewall In Use” checkbox, if your location is using a Firewall with network
address translation.

Firewall IP Address
The Firewall IP Address.

Firewall HPEG Port
The Port on the Firewall that should be used for HPEG traffic.

6.2 HPEG Configuration and Status
This section describes the items in the main window HPEG toolbar.

11
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HPEG User
This indicates if your user account is Enabled or Disabled for HPEG.

HPEG Commanding
This indicates if you are enabled or disabled for HPEG commanding.

Ku Forward
This indicates if Ku Forward is Enabled or Disabled.

Ku Return
This indicates if Ku Return is Enabled or Disabled.

Increment
This displays the increment you are logged into.

Operational Mode
This displays the operational mode you are logged into.

Idle Check

This indicates if the HPEG Idle Check is Enabled or Disabled. If you push the Enable
button the Idle Check will be enabled. If you push the Disable button, the Idle Check
will be disabled. If the Idle Check is disabled, you will not be prompted when your
HPEG session goes idle.

6.3 HPEG Messages

The HPEG Messages dialog is shown in Figure 13. It is available from the HPEG menu.
This dialog displays HPEG messages associated with HPEG Destinations.

- HPEG Messages N &léj

e — .

GMT 2014-04-10 17:39:39 Payload®31: Successfully Initialized (0)

Figure 13 HPEG Messages

12
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6.4 Application Messages

Various types of application messages are generated including information, progress,
warning, error, and debug messages. Information, warning, and error messages will be
displayed in the main window message area. All application messages are sent to the
Messages dialog shown in Figure 14. The Messages dialog can be configured to display
specific types of messages. By default, the Messages dialog will display information,
progress, warning, and error messages. Columns in the Messages dialog can be sorted by
clicking on the column header. The Messages dialog is available from the Options menu.

ﬂ Messages @%

Time Category Message m

(GMT 2014-08-15 16:51:56:171 ¢ Progress HPEG Proxy Init Message: PayloadX31 Reason: Successfully Initialized (0.

GMT 2014-08-15 16:51:56:170 Progress Successfully sent request to start session for HPEG destination Paylead..,

GMT 2014-08-15 16:50:31:053 Progress The HPEG Ground Mode ID was successfully set to 345,

GMT 2014-08-15 16:50:31:053 Info Successfully activated support for HPEG.

GMT 2014-08-15 16:30:31:044 Info User selected Ground Mode ID 345

GMT 2014-08-15 16:50:30:648 Progress Received HPEG Approved Services -

Configure... ] [ Clear... ] [ Export... ]

Figure 14 Messages Dialog

Configure
The Configure button provides access to the Configure Messages dialog shown in Figure

15. This dialog is used to filter the types of messages (category) displayed in the
Messages dialog.

- ™
Configure Messages Q @lﬂ

Digplay: Info Progress Warning Error [ | Debug

[ oK ] [ Cancel

E_

Figure 15 Configure Messages Dialog

Clear

The Clear button provides access to the Clear Messages dialog shown in Figure 16. This
dialog provides two ways to clear messages in the Messages dialog. You can clear all the
messages or clear selected messages. Once you clear messages, the messages are
permanently deleted.

13
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m Clear Messages L 2 ﬁ]

@ Clear All Messages

1 Clear Selected Messages

OK ] I Cancel

| C—

Figure 16 Clear Messages Dialog

Export
The Export button provides the capability to save all the application messages to a file.

When you push the Export button you will be prompted for a directory and filename.
Export will save all messages, not just the messages currently displayed in the Messages
dialog (i.e. the ‘Configure’ filter is not applied). The name you provide for the file will
be modified with a time tag prefixed to the filename. The time tag indicates the time the
file was closed. For example:

Filename Input: messages.txt
Filename Output: GMT_2014-04-10_16~57~27~182_messages.txt.

6.5 Advanced Settings

The Advanced Settings dialog provides access to timeout values used in communication
with the Huntsville Operations Support Center. It is unlikely there would ever be a need
to modify these settings. The settings can only be modified when the HPEG service is
inactive. The Advanced Settings dialog is shown in Figure 17.

e . N
Bl ~dvanced Settings [ 2 ﬁ]

ERIS Communication Timeout (miliseconds): | 10000

HPEG Communication Timeout (miliseconds): 10000

[ oK ] I Cancel

h——— —————————————

Figure 17 Advanced Settings Dialog

6.6 Application Settings

The HPEG application saves application settings each time you exit the application. The
next time you run the application, the application will initialize with the previous settings.
The following settings are saved:

14
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Application Window Size

Application Window Position

POIC Host Name or POIC IP Address Selection
POIC Host Name Entry

POIC IP Address Entry

HPEG Port Entry

Firewall In Use Selection

Firewall IP Address Entry

Firewall Port Entry

Firewall HPEG Port Entry

Configure Messages Checkbox Selections
Advanced Settings

7 FAQ and Troubleshooting

This section addresses Frequently Asked Questions and provides tips for troubleshooting
common gotchas.

No FAQs Yet.

15



