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1 Welcome

The Telescience Resource Kit (TReK) is a suite of software applications and libraries that
can be used to monitor and control assets in space or on the ground.

The TReK Playback application provides the capability to playback recorded data.

This tutorial provides step-by-step instructions describing how to perform common
application functions.

The topics in this tutorial require an understanding of the topics covered in the TReK
Concepts document and the TReK Data User Guide. Please be sure you have read these
documents before proceeding with this tutorial.

This tutorial uses screen dumps taken on a Windows computer. However, the steps are
the same regardless of whether you are running on Windows or Linux.

2 Technical Support

If you are having trouble installing the TReK software or using any of the TReK
software, please contact us for technical assistance:

TReK Help Desk E-Mail, Phone & Fax:

E-Mail: trek.help@nasa.gov
Telephone:  256-544-3521 (8:00 a.m. - 4:00 p.m. Central Time)
Fax: 256-544-9353

If you call the TReK Help Desk and you get a recording please leave a message and
someone will return your call. E-mail is the preferred contact method for help. The e-
mail message is automatically forwarded to the TReK developers and helps cut the
response time. The HOSC Help Desk (256-544-5066) can provide assistance as needed
and is available 24x7.

3 Introduction

The TReK Playback application provides the capability to play back data stored in data
recording files and forward the data. The TReK Data application can be used to receive
the forwarded data and perform any of the functions available in the data application such
as processing the data and displaying it. The configuration of the TReK Playback
application can be saved.
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4 Overview of the User Interface

4.1 Main Window

The main window is shown in Figure 1. The main window consists of two areas. The
top part of the main window contains statistics information about the playback in
progress. It will be empty until a playback is started. The bottom part of the window is a
message area that is used to display important status and information messages about the
activities in progress.

The Message Area is a dock window that you can float or dock. To float a dock window,
use your left mouse button to click and hold the title area while dragging the window to
another area of the screen. To dock, use the title bar to drag the dock window over the
main window and drop.

P TReK Playback -- Untitled

File View Playback Options Help

Configuration: . Configure | Operational . Activate Deactivate Playback: | Wb ke Status: Inactive .

Mame State Packet Type DeviceKey PkisRovd Phis Sent

Message Area g X

Ready

Figure 1 Main Window

Configuration Toolbar
The Configuration toolbar provides the capability to configure the playback, Activate the
playback, and Deactivate the playback.

Playback Toolbar

The Playback toolbar provides access to the playback controls. The control buttons
provide the capability to Start, Pulse, Pause, or Stop a playback. The Status area to the
right of the controls displays the status of the playback.

Statistics Area
The Statistics area provides real time statistics information for active services.
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Message Area
The Message Area displays important information, warning and error messages. The

message area can be cleared using the View menu.

4.2 Menus

The application menus are: File, View, Playback, Options, and Help. Each of these
menus is described in more detail below.

File Menu
The File menu provides the capability to create a new configuration, open a
configuration, save a configuration, and exit the application.

View Menu
The View menu provides the capability to clear the main window message area and show
and hide the statistics area and the main window message area.

Playback Menu

The Playback menu provides the capability to configure, activate, and deactivate a
playback. Once a playback has been activated, the Playback menu will also display menu
items to control the playback.

Options Menu
The Options menu provides the capability to access statistics, reset statistics, and

configure statistics snapshot recording. It also provides access to the Messages dialog
which can be used to display and filter application messages.

Help Menu
The Help menu provides access to on-line help and application version information.

5 TReK Playback Tour

Sometimes it’s easier to learn how to use an application by example. This section
describes how to use the Playback application to play data back from a recorded data file.

This section was written assuming you have read the Introduction section and the Main
Window section. If you have not read these sections, please go back and read them.
They contain important information that is not repeated in this section.

The tutorial assumes you are familiar with the material in the TReK Data User Guide and
have worked through the TReK Data Tutorial. To complete this tutorial, you will need
access to the data recording file that was generated as part of the TReK Data tutorial. If
you have not completed the TReK Data Tutorial please go through that tutorial before
working through this one.
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If at any time you need to exit the applications so you can resume working through the
Tutorial at a later time, File Save will allow you to save all the data you entered.

Please go through the tourin order. Some sections depend on data from previous
sections.

5.1 Step-By-Step
This section provides step-by-step instructions that show how to use the TReK Playback
application to configure and start a playback.

1. Go to the operating system’s menu to start the TReK Playback application. You
should see the TReK Playback main window shown in Figure 2.

P TReK Playback -- Untitled

File View Playback Options Help

Configuration: . Configure | Operational . Activate Deactivate Playback: | Wb ke Status: Inactive .

Mame State Packet Type DeviceKey PkisRovd Phis Sent

Message Area

Ready

Figure 2 TReK Playback Main Window

2. Push the Configure button to configure the playback. You should see the dialog
shown in Figure 3.
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P Configure

Playback Forward Cryptography

General Decrypt

Files
File Packet Type I Browse... |
Delete
Update Packet Type...
[ 1gnore Start/Stop Times on Individual Files and Synchronize Playback Using This Master Start/Stop Time
Start Time: | 2000-01-01 00:00:00.0 5 | Stop Time: 2000-01-01 00:00:00.0 %
Playback Order
Playback Order: Order Received -
Reorder Queue Size (bytes): 0
Playback Rate Playback Mode Playback Pulse
(®) # Packets/Sec: (O Indefinitely # Packets/Pulse:
() # Bits/Sec: 20000 (®) specific # Times:
() Mative Scale: i
oK Cancel

Figure 3 Configure Dialog

3. Inthe Files area, push the Browse button to add a recorded data file. The Open
dialog will default to the trek_workspace/recorded_data directory. If you
successfully completed the TReK Data Tutorial, you should see a recorded data
file similar to the one shown in Figure 4.
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Figure 4 TReK Workspace RecordedData Directory

4. Select the file with a name similar to Packet24 2017-06-13 16~11~03 and push
the Open button. The Configure dialog should look similar to the one shown in
Figure 5. The playback will be configured to play data back from this recorded
data file.
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P Configure
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Start Time: | 2000-01-01 00:00:00.0 5 | Stop Time: 2000-01-01 00:00:00.0 %

Playback Order

Playback Order: Order Received -

Reorder Queue Size (bytes): 0

Flayback Rate Flayback Mode Flayback Pulse

(®) # Packets/Sec: (O Indefinitely # Packets/Pulse:
() # Bits/Sec: 20000 (®) specific # Times:

() Mative Scale: i

oK Cancel

Figure 5 Recorded Data File Added to List

5. There are multiple settings to customize the playback. For this playback use the
default settings as shown in Figure 5. The Playback Order will play the packets in
the file back using the Embedded Time. The Playback Rate is set to #Packets/Sec
with a value of 1. So 1 packet will be played back once a second. The Playback
Mode is setto run the playback 1 time. If the playback is pulsed, one packet will
be sent each time the Pulse button is pushed.

6. Select the Forward Tab as shown in Figure 6. To work with the data being played
back you need to forward it to another application or computer.
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P Configure
Playback  Forward Cryptography
Destination List Transform Encrypt
Network DTN
Mame Protocol Destination IP Address  Destination Port  Local IP Address  Local Port Add
Delete
Cancel

Figure 6 Forward Tab

7. Inthe Forward tab, push the Add button to add a row to the Network Destination
List. In the row enter the following information as shown in Figure 7. The Local
IP Address should default to the correct address — if it doesn’t please enter the
correct address. The Name can be anything you would like. TReK Data was
used here as a hint to configure the TReK Data application to receive and display

the data.

Name: TReK Data

Protocol: UDP

Destination IP Address: <Enter your local IP Address>
Destination Port: 6100

Local IP Address: <Enter your local IP Address>
Local Port: 0



TREK-USER-0023

P Configure
Playback  Forward Cryptography
Destination List Transform Encrypt
Network DTN
Mame Protocol Destination IP Address  Destination Port  Local IP Address  Local Port Add
TRek Data upp 192.168.50.14 6100 192.168.50.14 0 Dalete
oK Cancel

Figure 7 Forward Tab Network Tab Populated

This will forward all the data played back to the Destination IP Address and Port

identified. 1f you would like you can configure the TReK Data application to
receive the data and display it.

8. Push the OK button to close the Configure dialog. Your Main Window
should look like the one in Figure 8.
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P TReK Playback -- Untitled

Eile View Playback Options Help

Configuration: . Configure | Operational . Activate Deactivate Playback: | ‘r~ UL L Status: Inactive .

Mame State Packet Type DeviceKey PktsRovd  Pkts Sent

Message Area

Figure 8 Main Window with Playback Configured

9. Now that the playback is configured, it needs to be activated. Push the
Activate button. The Main Window should look like the one show in Figure

9.

P TReK Playback -- Untitled

Eile View Playback Options Help
Configuration: . Configure | Operational . Activate Deactivate Playback: | Mp- Ll e Status: Inactive .
Marme State Packet Type Device Key Pkts Rewd  Pkts Sent
1.1.192.168.50.14.60822.1 Start 1.1.192.168.50.14.60822.1 ] ]
PlaybackServicePlaybackLibrary  Stop 4 PlaybackServicePlaybackLibrary 0 0
Message Area g X
v U He s HiTa H o acce B ~
24 2017-05-16_21~05~35 {file_device.cpp:273)
GMT 2017-05-16 21:48:58:350 Info: Successfully dosed file with pathname: C:\Jsers'mps\trek_workspace'recorded_data\Packet
24_2017-05-16_21~05~35 (fle_device.cpp:611)
GMT 2017-05-16 21:48:58:350 Info: Successful CreateFile with pathname: C:\Users\mps\irek_workspace \recorded_data\Packet
24_2017-05-16_21~05~35 (file_device.cpp: 278)
GMT 2017-05-16 21:48:58:362 Info: Successfully activated service PlaybackService W

Figure 9 Main Window with Playback Activated
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10. Now that the Playback is Active, you can see the Playback Controls in the top
right of the Main Window are enabled. You canalso see that the Statistics area is
now populated with information. Push the Start Button (Green Arrow) to start the
playback. Your Main Window should look similar to the one in Figure 10.

P TReK Playback -- Untitled

File View Playback Options Help

Configuration: . Configure | Operational . Activate Deactivate Playback: | Wb B Status: Running .

Mame State Packet Type Device Key Pkts Rovd  Plts Sent

aCKLinrary o I

Message Area

v 21 Jo-1b e i Mt (] [*H O = (] Eale
24 2017-05-16_21~05~35 (file_device.cpp:278)
GMT 2017-05-16 21:48:58:362 Info: Successfully activated service PlaybackService
GMT 2017-05-16 21:49:07:458 Info: Successfully dosed file with pathname: C:\Users\mps\trek_workspace'recorded_data\Packet
24 2017-05-16_21~05~35 (file_device.cppi611)
GMT 2017-05-16 21:49:07:458 Info: Successful CreateFile with pathname: C:\Users\mps©trek_workspace\recorded_data\Packet
24 2017-05-16_21~05~35 (file_device.cpp:278)

Figure 10 Main Window with Playback Running

You can see that the both lines in Statistics are showing Pkts Sent incrementing. This
indicates that the Playback is playing packets back from the file and the packets are being
forwarded to the Destination and Port you identified when you configured the playback.
If you would like to see additional details, use the right mouse button to access the
Statistics Pop-Up menu and select Device and Packet Statistics and Expand All. Your
Statistics area should have expanded to look similar to the one shown in Figure 11. This
view shows you the packet key associated with the data being played back.

11
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P TReK Playback -- Untitled

Eile View Playback Options Help

Configuration: [l | Configure | Operational [l = Activate Deactivate Playback: -\~ Wl | Status: Running [l
Marme State Packet Type Device Key Pkts Rcwd  Pkts Sent
v 11.1.192,168.50.14.60822.1 i Start 0 18
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v PlaybackServicePlaybackLibrary Start 0 18
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GMT 2017-05-16 21:49:07:458 Info: Successfully dosed file with pathname: C:\Jsers'mps\trek_workspace'recorded_data‘\Packet
24 2017-05-16_21~05~35 (fle_device.cpp:611)
GMT 2017-05-16 21:43:07:458 Info: Successful CreateFile with pathname: C:\Users\mps\trek_workspace\recorded_data\Packet
24_2017-05-16_21~05~35 (file_device.cpp: 278) v

Figure 11 Device and Packet Statistics

Congratulations you have successfully configured and run a playback!
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