
TREK-USER-0015 

 
 
 
 

TREK  
 

HOSC LOGIN 
 

USER GUIDE 
 
 
 

 
 
 

 
 
 
 

 
 

January 2020 
 
 
 

Approved for Public Release; Distribution is Unlimited.
 



TREK-USER-0015 

 i 

TABLE OF CONTENTS 
 

PARAGRAPH         PAGE 
 

1 Welcome ..............................................................................................................1 
1.1 Getting Started......................................................................................................................................... 1 

2 Technical Support ...............................................................................................1 

3 Introduction ........................................................................................................1 

4 Overview of the User Interface............................................................................2 
4.1 Main Window.......................................................................................................................................... 2 
4.2 Toolbar..................................................................................................................................................... 3 
4.3 Menus....................................................................................................................................................... 3 

5 Quick Start Guides ..............................................................................................4 
5.1 How to Start a Login Session with the HOSC ...................................................................................... 4 
5.2 How to Change Your HOSC Login Password ...................................................................................... 4 
5.3 How to Re-Authenticate your HOSC Login ......................................................................................... 4 
5.4 How to Request a HOSC Login Re-Authentication Status .................................................................. 5 
5.5 How to Request HOSC Common Information ..................................................................................... 5 

6 Details ..................................................................................................................5 
6.1 Main Window Login Area...................................................................................................................... 5 
6.2 Advanced Settings................................................................................................................................... 6 
6.3 Application Messages ............................................................................................................................. 7 
6.4 Application Settings .............................................................................................................................. 10 

7 FAQ and Troubleshooting.................................................................................10 

 



TREK-USER-0015 

 ii 

FIGURES 
 

FIGURE          PAGE 
 
Figure 1 Main Window.......................................................................................................................................... 2 
Figure 2 Main Window General Tab .................................................................................................................... 5 
Figure 3 Advanced Settings Dialog ...................................................................................................................... 6 
Figure 4 Messages Dialog ..................................................................................................................................... 8 
Figure 5 Configure Messages Dialog ................................................................................................................... 8 
Figure 6 Clear Messages Dialog ........................................................................................................................... 9 



TREK-USER-0015 

 1 

1 Welcome 
The Telescience Resource Kit (TReK) is a suite of software applications and libraries that 
can be used to monitor and control assets in space or on the ground.   
 
The TReK HOSC Login application provides the capability to create a login session with 
the Huntsville Operations Support Center (HOSC) that can be shared across TReK 
applications (e.g. HPEG, Command). 
 

1.1 Getting Started 
Start with the Introduction which provides an application overview.  Next, try the Quick 
Start Guides for “How Tos” for common functions.  For help with details, reference the 
Details section.  See the FAQ and Troubleshooting section for helpful hints and solutions 
to the common “gotchas”. 
 
 

2 Technical Support 
If you are having trouble installing the TReK software or using any of the TReK 
software, please contact us for technical assistance: 
 
TReK Help Desk E-Mail, Phone & Fax: 
 
E-Mail:            trek.help@nasa.gov 
Telephone:      256-544-3521 (8:00 a.m. - 4:00 p.m. Central Time) 
Fax:                 256-544-9353 
 
If you call the TReK Help Desk and you get a recording please leave a message and 
someone will return your call.  E-mail is the preferred contact method for help.  The e-
mail message is automatically forwarded to the TReK developers and helps cut the 
response time.  The HOSC Help Desk (256-544-5066) can provide assistance as needed 
and is available 24x7. 
 
 

3 Introduction 
The TReK HOSC Login application provides the capability to create a login session with 
the Huntsville Operations Support Center (HOSC).  This login session can be shared 
across TReK applications (e.g. HPEG, Command). 
 
Important Note:  Please use Port 9219 when logging into the HOSC.  Port 9209 is no 
longer supported by the HOSC.  If you have been using port 9209 in the TReK HOSC 
Login application, this will continue to be the default until you change it. The TReK 
HOSC Login application and the TReK ERIS Sim Console application use the Transport 
Layer Security (TLS) for all ports except 9209.  The TReK ERIS Sim Console 
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application’s eris_sim_properties.xml configuration file contains a port number 
configuration parameter that controls the port used by the simulator.  When working with 
the simulator you are free to choose which ports to use, but we suggest using port 9219 
for the simulator.  If you wish to use TLS with TReK ERIS Sim Console, you can copy 
the eris_sim_properties.xml file from the install to your home directory and edit the IP 
address.  
  
 

4 Overview of the User Interface 

4.1 Main Window 
The main window contains several areas as shown in Figure 1.  The Message Area is a 
dock window that you can float or dock.  To float a dock window, use your left mouse 
button to click and hold the title area while dragging the window to another area of the 
screen.  To dock, use the title bar to drag the dock window over the main window and 
drop. 
 

 
Figure 1 Main Window 

Toolbar 
The toolbar at the top of the window provides quick access to Login and Logout.  
 
Login 
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The Login area provides the capability to enter the information required to establish a 
login session with the HOSC.   
 
Message Area 
The Message Area displays important status and error messages.  The message area can 
be cleared using the View menu. 
 
 

4.2 Toolbar 
The toolbar provides visual information about the state of the application and provides 
access to common application functions.   
 
Operational Status 
When the Operational status is black, this indicates the login session is inactive.  When 
the Operational status is green, this indicates the login session is active. 
 
Use the Login button to establish a login session with the HOSC.  Use the Logout button 
to exit the login session.   
 
 

4.3 Menus 
The HOSC Login application menus are:  File, View, Options, and Help.  Each of these 
menus is described in more detail below. 
 
File Menu 
The File menu provides the capability to exit the application.   
 
View Menu 
The View menu provides the capability to clear the main window message area and show 
and hide different areas in the main window.   
 
Options Menu 
The Options menu provides the capability to change your HOSC password, re-
authenticate your HOSC login, request a HOSC login re-authentication status, and 
request HOSC common information.  It also provides access to the Messages dialog 
which can be used to display and filter application messages.  Access to advanced 
settings is also available. 
 
Help Menu 
The Help menu provides access to on-line help and application version information. 
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5 Quick Start Guides 
This section provides “How Tos” for common functions. 

5.1 How to Start a Login Session with the HOSC 
The following steps describe the minimum necessary to start a login session with the 
HOSC.  For additional information and details please reference section 6.1. 
 
1. Enter a name for the login session in the HOSC Login Name field.   

 
Note:  You will use this name when referencing the login session from other TReK 
Applications (e.g. HPEG, Command). 
 

2. Enter a local IP address in the Local IP Address field.   
 
Note:  If you are connecting to the HOSC, and have established a VPN Client login, 
you should enter the Office Mode IP Address assigned by the VPN Client.  If you are 
connecting to a TReK training tool that is simulating the HOSC login, enter your 
computer’s local IP address.  You can use the Browse button to view and select a 
local IP Address.   
 

3. Enter the HOSC information. 
a. Enter either the HOSC Host Name or the HOSC IP Address.  
b. Enter the HOSC Port. 

 
Note:  If you are connecting to the HOSC, enter the HOSC Host Name or IP Address 
and the HOSC Port.  If you are connecting to a TReK training tool that is simulating 
the HOSC login, enter the IP Address and Port corresponding to the configuration of 
the training tool.  For example, if you are running the training tool on the same 
computer as the HOSC Login application, then you would use your local IP address 
for the Local IP Address and the HOSC IP Address. 
 

4. Push the Login button to activate the login sequence.  You will see a series of dialogs 
requesting information such as Username, Password, Passcode, Role, and Mission 
Operational Support Mode (MOP).  Enter the information requested. 

 
Note:  The Passcode is your PIN number followed by your RSA token number. 
 

If the login session is successfully activated, the Operation status will be green. 
 

5.2 How to Change Your HOSC Login Password 
The Options menu provides the capability to initiate a HOSC password change. 
 

5.3 How to Re-Authenticate your HOSC Login 
The Options menu provides the capability to initiate a HOSC login re-authentication. 
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5.4 How to Request a HOSC Login Re-Authentication Status  
The Options menu provides the capability to request a HOSC login re-authentication 
status. 
 

5.5 How to Request HOSC Common Information 
The Options menu provides the capability to request HOSC Common Information.  This 
includes various types of information such as project, mission, and database information. 
 

6 Details 
This section covers various application details. 

6.1 Main Window Login Area 
The Main Window Login Area is shown in Figure 2.  Each field is described below. 
 
 

 
Figure 2 Main Window General Tab 

 
 
HOSC Login Name 
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The HOSC Login Name should contain a name for the login session.  You will need this 
name when referencing the login session from other TReK Applications (e.g. HPEG, 
Command). 
 
Local IP Address 
The Local IP Address is used to perform network communication when establishing the 
login session.  If you are connecting to the HOSC, and have established a VPN Client 
login, you should enter the Office Mode IP Address assigned by the VPN Client.  If you 
are connecting to a TReK training tool that is simulating the HOSC login, enter your 
computer’s local IP address.  You can use the Browse button to view and select a local IP 
Address.   
 
HOSC Information 
HOSC information fields include the HOSC Host Name, HOSC IP Address, and HOSC 
Port.    If you are connecting to the HOSC, enter the HOSC Host Name or IP Address and 
the HOSC Port.  If you are connecting to a TReK training tool that is simulating the 
HOSC login, enter the IP Address and Port corresponding to the configuration of the 
training tool.  For example, if you are running the training tool on the same computer as 
the HOSC Login application, then you would use your local IP address for the Local IP 
Address and the HOSC IP Address. 
 

6.2 Advanced Settings 
The Advanced Settings dialog provides access to configure several advanced settings.  
The Advanced Settings dialog is shown in Figure 3. 
 

 
Figure 3 Advanced Settings Dialog 

 
Communication Timeout 
You can set the timeout value used in communication with the Huntsville Operations 
Support Center.   It is unlikely there would ever be a need to modify this setting.  The 
timeout value can only be modified when the Login session is inactive.   
 
Log TReK ERIS Interface Messages 
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The TReK HOSC Login application provides the capability to log messages that are 
exchanged between the TReK HOSC Login application and the HOSC ERIS software to 
a file.  This capability has been provided for troubleshooting purposes.  Hopefully this is 
a feature you will never need to use.  If you check the Log TReK ERIS Interface 
Messages checkbox, the messages that are exchanged between the TReK HOSC Login 
application and the HOSC ERIS software will be written to the log file specified.  
Message Logging will start when the Login Session is activated and stop if you uncheck 
the box or the Login Session is deactivated.  Once a log file exists, any new messages 
will be appended to the existing log file. 
   
Log Directory  
The Log Directory field should contain the absolute path to the directory where the log 
file should be written.  
   
Log Filename 
The Log Filename field should contain the name to use for the log file. 
 
 

6.3 Application Messages 
Various types of application messages are generated including information, progress, 
warning, error, and debug messages.  Application messages are stored in memory and 
written to a temporary log file.  The temporary log file is created on application 
initialization and exists as long as the application is running.  It is deleted when you exit 
the application.  The log file is located in the temporary directory provided by the 
operating system.  Only a subset of messages are stored in memory while all messages 
are written to the temporary log file.  The maximum number of application messages 
stored in memory is controlled by the message storage setting in the Configure Messages 
dialog.  Once the maximum is reached, older messages are deleted to make room for new 
messages.  Setting the maximum value to a large number can impact application 
performance since it will increase the amount of memory used by the application.  Setting 
this number too low can cause you to miss important messages.  The application default 
was selected to protect against both of these scenarios.  Messages stored in memory are 
displayed in the Main Window Message Area and the Messages dialog.  The Messages 
dialog is shown in Figure 4.  The Main Window message area only displays Info, 
Warning, and Error messages.  The Messages dialog displays messages based on the 
display preferences defined in the Configure Messages dialog.  By default, the Messages 
dialog will display information, progress, warning, and error messages.  Columns in the 
Messages dialog can be sorted by clicking on the column header.  The Messages dialog is 
available from the Options menu.   
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Figure 4 Messages Dialog 

 
Configure 
The Configure button provides access to the Configure Messages dialog shown in Figure 
5.  This dialog provides access to preferences associated with messages.  Display 
preferences can be set to filter the types of messages (category) displayed in the 
Messages dialog.  Export Preferences control how the time tag is added to the filename 
that is created when messages are exported.  See the Export section for details.  Message 
storage defines the maximum number of messages that will be stored in memory while 
the application is running.  Once the maximum is reached, older messages are deleted to 
make room for new messages.  The Set to Defaults button can be used to reset these 
properties to application defaults. 
 
 

 
Figure 5 Configure Messages Dialog 

 
 
Clear 
The Clear button provides access to the Clear Messages dialog shown in Figure 6.  This 
dialog provides two ways to clear application messages stored in memory.  You can clear 
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all the messages or clear selected messages.  Once you clear messages, the messages are 
permanently deleted in all views (Main Window Message Area and the Messages dialog). 
 

 
Figure 6 Clear Messages Dialog 

 
 
Export 
The Export button provides the capability to save all the application messages currently 
in memory to a file.  When you push the Export button you will be prompted for a 
directory and filename.  Export will save all messages in memory, not just the messages 
currently displayed in the Messages dialog (i.e. the Display Preferences are not applied).  
The name you provide for the file will be modified with a time tag that is added to the 
filename.  The time tag indicates the time the file was closed.  The default is to append 
the time tag to the filename.  For example: 
 
Filename Input:   messages.txt 
Filename Output: messages_2017-05-07_13~03~28.txt 
 
If you would like to prepend the time tag to the filename you can set this preference in 
the Configure Messages dialog.  This would result in the following: 
 
Filename Input:   messages.txt 
Filename Output: 2017-05-07_13~03~28_messages.txt 
 
 
Delog 
The Delog button provides the capability to save all application messages generated since 
the application was started.  Delog will retrieve the messages from the temporary log file.  
When you push the Delog button you will be prompted for a directory and filename.  A 
timetag is not applied to the filename. 
 
Filename Input:   messages.txt 
Filename Output: messages.txt 
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6.4 Application Settings 
The HOSC Login application saves some settings as application settings each time you 
exit the application.  The next time you run the application, the application will initialize 
with the previous application settings.  Only one set of settings are saved.  If you run 
multiple instances of the application, the settings in the instance that is exited last will be 
saved.  The following application settings are saved: 
 
 Application Window Size 
 HOSC Login Name 
 HOSC Host Name or HOSC IP Address Selection 
 HOSC Host Name Entry 
 HOSC IP Address Entry 
 HOSC Port Entry 
 Configure Messages Selections 
 Advanced Settings 

 

7 FAQ and Troubleshooting 
This section addresses Frequently Asked Questions and provides tips for troubleshooting 
common gotchas. 
 
No FAQs Yet. 
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