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1 Welcome

The Telescience Resource Kit (TReK) is a suite of software applications and libraries that
can be used to monitor and control assets in space or on the ground.

The TReK Settings application displays information about TReK settings.

1.1 Getting Started

Start with the Introduction which provides an application overview. Next, try the Quick
Start Guides for “How Tos” for common functions. For help with details, reference the

Details section. See the FAQ and Troubleshooting section for helpful hints and solutions
to the common “gotchas”.

2 Technical Support

If you are having trouble installing the TReK software or using any of the TReK
software, please contact us for technical assistance:

TReK Help Desk E-Mail, Phone & Fax:

E-Mail: trek.help@nasa.gov
Telephone:  256-544-3521 (8:00 a.m. - 4:00 p.m. Central Time)
Fax: 256-544-9353

If you call the TReK Help Deskand you get a recording please leave a message and
someone will return your call. E-mail is the preferred contact method for help. The e-
mail message is automatically forwarded to the TReK developers and helps cut the
response time. The HOSC Help Desk (256-544-5066) can provide assistance as needed
and is available 24x7.

3 Introduction

The TReK Settings application displays information about TReK settings such as the
location of the TReK workspace folder and values for environment variables used by the
TReK software. The settings are configured during installation and there is no need to
change the settings. However, if a need arises, the settings can be changed using
capabilities provided by the operating system (e.g. Windows System Properties or Linux
login shell). Changing these settings requires administrative privileges.
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4 Overview of the User Interface

4.1 Main Window

The main window contains several areas as shown in Figure 1. The Message Area is a
dock window that you can float or dock. To float a dock window, use your left mouse
button to click and hold the title area while dragging the window to another area of the
screen. To dock, use the title bar to drag the dock window over the main window and
drop.

. TReK Settings

File View Options Help

TReK Workspace

TRek Workspace Directory: |C:,ﬂ_lsErs,.'_,ﬁ:rek_'.f\'c:rk5|:|c'u:E,f |

TReK Environment Variables

TREK_INCLUDE: |C:;’Program Files/TRek 5. 2.0/indude

TREK_LIB: |C:fPrc-grarn Files/TRek 5.2.0/lb/VS2017fx54

TREK_LIB&+: |C:fProgram Files/TRek 5.2.0/lb/N52017 fx64

|
|
TREK_LIB32:  |C:/Program Files/TReK 5.2,0/ib/V52017/WWin32 |
|
|

TREKROOT: |C:;’Pr0gram Files/TReK 5.2.0

Message Area g x

GMT 2019-12-04 23:37:04:979 Info: The trek_workspace is in default location. The TREK_WORKSPACE environment variable does not exist,

Ready

Figure 1 Main Window

TReK Workspace
The TReK Workspace area displays information about the current location of the TReK
workspace.

TReK Environment Variables
The TReK Environment Variables area displays information about TReK environment
variables. The environment variables listed will differ on Windows and Linux.

Message Area
The Message Area displays important status and error messages. The message area can

be cleared using the View menu.

4.2 Menus

The TReK Settings application menus are: File, View, Options, and Help. Each of these
menus is described in more detail below.

File Menu
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The File menu provides the capability to exit the application.

View Menu
The View menu provides the capability to clear the main window message area and show
and hide different areas in the main window.

Options Menu

The Options menu provides the capability to export the settings information. It also
provides access to the Messages dialog which can be used to display and filter application
messages.

Help Menu
The Help menu provides access to on-line help and application version information.

5 Quick Start Guides
This section provides “How Tos” for common functions.

5.1 How to Change the TRe K Workspace
The following steps describe how to change the location of the TReK Workspace.

1. Exit all TReK software applications, any applications that use the TReK API, and any
TReK services.

Note: This is very important. Do not change the TReK Workspace while the TReK
software is running.

2. Use the operating system to create an environment variable named
“TREK_WORKSPACE” (without the quotes).

Note: On Windows, use the Windows System Properties Environment Variables. On
Linux modify your login shell script.

3. Setthe TREK_WORKSPACE variable value to the directory where you want the
workspace to reside. For example: D:\GroundSyste mFiles\

Note: The TReK workspace will be created in the new location when you start one of
the following applications: Data, Playback, Command, or Metadata.

5.2 How to Export Settings Information

The Export Settings dialog provides the capability to export settings. It is available from
the Options menu.
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6 Details
This section covers various application details.

6.1 Main Window Area
The Main Window Area is shown in Figure 2. Eachfield is described below.

. TReK Settings

File View Options Help

TReK Workspace

TReK Workspace Directory: |C:Nsers,.’_;’t’ek_v\'orkspace,.’ |

TReK Environment Variables

TREK_INCLUDE: |C:Program Files/TRek 5. 2.0/indude

TREK_LIB: |C:Program Files/TRek 5. 2.0/lb/N52017 fx64

TREK_LIBG4: |C:,|'Program Files/TRek 5.2.0/lb/V52017/x54

|
|
TREK_LIB32: |C:fProgram Files/TRek 5.2.0/lb/V52017Win32 |
|
|

TREKROOT: |C:,|'Program Files/TRek 5.2.0

Message Area g X

GMT 2019-12-04 23:37:04:979 Info: The trek_workspace is in default location. The TREK_WORKSPACE environment variable does not exist,

Ready

Figure 2 Main Window Area

TReK Workspace
The TReK Workspace Directory displays the location where the TReK software expects
to find the TReK waorkspace.

TReK Environment Variables
The TReK Environment Variables area lists all the environment variables used by the
TReK software. The environment variables listed will differ on Windows and Linux.

6.2 Export Settings Dialog

The Export Settings dialog is shown in Figure 3. This dialog can be used to write the
information displayed in the Main Window area to a file.
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. Export Settings

Flease enter a filename and directory for the settings export file:

Filename: |trek_settings.b(t |

Directory: |C:J'Llsers;'kirk | I |

Ok Cancel

Figure 3 Export Settings Dialog

Each field is described below.

Filename
The Filename field is used to enter the filkname for the file that will be created.

Directory
The Directory field is used to enter the directory where the file should be written.

6.3 Application Messages

Various types of application messages are generated including information, progress,
warning, error, and debug messages. Application messages are stored in memory and
written to a temporary log file. The temporary log file is created on application
initialization and exists as long as the application is running. Itis deleted when you exit
the application. The log file is located in the temporary directory provided by the
operating system. Only a subset of messages are stored in memory while all messages
are written to the temporary log file. The maximum number of application messages
stored in memory is controlled by the message storage setting in the Configure Messages
dialog. Once the maximum is reached, older messages are deleted to make room for new
messages. Setting the maximum value to a large number can impact application
performance since it will increase the amount of memory used by the application. Setting
this number too low can cause you to miss important messages. The application default
was selected to protect against both of these scenarios. Messages stored in memory are
displayed in the Main Window Message Area and the Messages dialog. The Messages
dialog is shown in Figure 4. The Main Window message area only displays Info,
Warning, and Error messages. The Messages dialog displays messages based on the
display preferences defined in the Configure Messages dialog. By default, the Messages
dialog will display information, progress, warning, and error messages. Columns in the
Messages dialog can be sorted by clicking on the column header. The Messages dialog is
available from the Options menu.
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. Messages

Time Category Message
(GRAT 2020-01-29 12:56:25:523 Info The trek_workspace is in default location. The TREK_WORK...
Configure... Clear... Export... Delog...

Figure 4 Messages Dialog

Configure

The Configure button provides access to the Configure Messages dialog shown in Figure
5. This dialog provides access to preferences associated with messages. Display
preferences can be set to filter the types of messages (category) displayed in the
Messages dialog. Export Preferences control how the time tag is added to the filename
that is created when messages are exported. See the Export section for details. Message
storage defines the maximum number of messages that will be stored in memory while
the application is running. Once the maximum is reached, older messages are deleted to
make room for new messages. The Set to Defaults button can be used to reset these
properties to application defaults.

Configure Messages

Messages Dialog Display Preferences

Info Progress Warning Error [ ] Debug

Export Preferences

[ ] when Exporting Messages Prepend the Timestamp to the Filename

Message Storage
Maximum Mumber of Messages Available for Display:
Set to Defaults Cancel

Figure 5 Configure Messages Dialog

Clear

The Clear button provides access tothe Clear Messages dialog shown in Figure 6. This
dialog provides two ways to clear application messages stored in memory. You can clear
all the messages or clear selected messages. Once you clear messages, the messages are
permanently deleted in all views (Main Window Message Area and the Messages dialog).
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v Clear Messages 7 X

(®) Clear All Messages

() Clear Selected Messages

Cancel

Figure 6 Clear Messages Dialog

Export
The Export button provides the capability to save all the application messages currently

in memory to a file. When you push the Export button you will be prompted for a
directory and filename. Export will save all messages in memory, not just the messages
currently displayed in the Messages dialog (i.e. the Display Preferences are not applied).
The name you provide for the file will be modified with a time tag that is added to the
filkname. The time tag indicates the time the file was closed. The default is to append
the time tag to the filename. For example:

Filename Input: messages.txt
Filename Output: messages_2017-05-07_13~03~28.txt

If you would like to prepend the time tag to the filkname you can set this preference in
the Configure Messages dialog. This would result in the following:

Filename Input: messages.txt
Filename Output: 2017-05-07_13~03~28_messages.txt

Delog
The Delog button provides the capability to save all application messages generated since

the application was started. Delog will retrieve the messages from the temporary log file.
When you push the Delog button you will be prompted for a directory and filename. A
timetag is not applied to the filename.

Filename Input: messages.txt
Filename Output: messages.txt

6.4 Application Settings

The Settings application saves some settings as application settings each time you exit the
application. The next time you run the application, the application will initialize with the
previous application settings. Only one set of settings are saved. Ifyou run multiple
instances of the application, the settings in the instance that is exited last will be saved.
The following application settings are saved:
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» Application Window Size
» Configure Messages Selections

7 FAQ and Troubleshooting

This section addresses Frequently Asked Questions and provides tips for troubleshooting
common gotchas.

No FAQs Yet.



	1 Welcome
	1.1 Getting Started

	2 Technical Support
	3 Introduction
	4 Overview of the User Interface
	4.1 Main Window
	4.2 Menus

	5 Quick Start Guides
	5.1 How to Change the TReK Workspace
	5.2 How to Export Settings Information

	6 Details
	6.1 Main Window Area
	6.2 Export Settings Dialog
	6.3 Application Messages
	6.4 Application Settings

	7 FAQ and Troubleshooting

