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1 Welcome 

The Telescience Resource Kit (TReK) is a suite of software applications and libraries that 

can be used to monitor and control assets in space or on the ground.   

 

The TReK HOSC Login application provides the capability to create a login session with 

the Huntsville Operations Support Center (HOSC) that can be shared across TReK 

applications (e.g. HPEG, Command). 

 

1.1 Getting Started 

Start with the Introduction which provides an application overview.  Next, try the Quick 

Start Guides for “How Tos” for common functions.  For help with details, reference the 

Details section.  See the FAQ and Troubleshooting section for helpful hints and solutions 

to the common “gotchas”. 

 

 

2 Technical Support 

If you are having trouble installing the TReK software or using any of the TReK 

software, please contact us for technical assistance: 

 

TReK Help Desk E-Mail, Phone & Fax: 

 

E-Mail:            trek.help@nasa.gov 

Telephone:      256-544-3521 (8:00 a.m. - 4:00 p.m. Central Time) 

Fax:                 256-544-9353 

 

If you call the TReK Help Desk and you get a recording please leave a message and 

someone will return your call.  E-mail is the preferred contact method for help.  The e-

mail message is automatically forwarded to the TReK developers and helps cut the 

response time.  The HOSC Help Desk (256-544-5066) can provide assistance as needed 

and is available 24x7. 

 

 

3 Introduction 

The TReK HOSC Login application provides the capability to create a login session with 

the Huntsville Operations Support Center (HOSC).  This login session can be shared 

across TReK applications (e.g. HPEG, Command). 

 

Important Note:  Please use Port 9219 when logging into the HOSC.  Port 9209 is no 

longer supported by the HOSC.  If you have been using port 9209 in the TReK HOSC 

Login application, this will continue to be the default until you change it. The TReK 

HOSC Login application and the TReK ERIS Sim Console application use the Transport 

Layer Security (TLS) for all ports except 9209.  The TReK ERIS Sim Console 



TREK-USER-0015 

 2 

application’s eris_sim_properties.xml configuration file contains a port number 

configuration parameter that controls the port used by the simulator.  When working with 

the simulator you are free to choose which ports to use, but we suggest using port 9219 

for the simulator.  If you wish to use TLS with TReK ERIS Sim Console, you can copy 

the eris_sim_properties.xml file from the install to your home directory and edit the IP 

address.  

  

 

4 Overview of the User Interface 

4.1 Main Window 

The main window contains several areas as shown in Figure 1.  The Message Area is a 

dock window that you can float or dock.  To float a dock window, use your left mouse 

button to click and hold the title area while dragging the window to another area of the 

screen.  To dock, use the title bar to drag the dock window over the main window and 

drop. 

 

 

Figure 1 Main Window 

Toolbar 

The toolbar at the top of the window provides quick access to Login and Logout.  

 

Login 
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The Login area provides the capability to enter the information required to establish a 

login session with the HOSC.   

 

Message Area 

The Message Area displays important status and error messages.  The message area can 

be cleared using the View menu. 

 

 

4.2 Toolbar 

The toolbar provides visual information about the state of the application and provides 

access to common application functions.   

 

Operational Status 

When the Operational status is black, this indicates the login session is inactive.  When 

the Operational status is green, this indicates the login session is active. 

 

Use the Login button to establish a login session with the HOSC.  Use the Logout button 

to exit the login session.   

 

 

4.3 Menus 

The HOSC Login application menus are:  File, View, Options, and Help.  Each of these 

menus is described in more detail below. 

 

File Menu 

The File menu provides the capability to exit the application.   

 

View Menu 

The View menu provides the capability to clear the main window message area and show 

and hide different areas in the main window.   

 

Options Menu 

The Options menu provides the capability to change your HOSC password, re-

authenticate your HOSC login, and request HOSC common information.  It also provides 

access to the Messages dialog which can be used to display and filter application 

messages.  Access to advanced settings is also available. 

 

Help Menu 

The Help menu provides access to on-line help and application version information. 

 

 

5 Quick Start Guides 

This section provides “How Tos” for common functions. 
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5.1 How to Start a Login Session with the HOSC 

The following steps describe the minimum necessary to start a login session with the 

HOSC.  For additional information and details please reference section 6.1. 

 

1. Enter a name for the login session in the HOSC Login Name field.   

 

Note:  You will use this name when referencing the login session from other TReK 

Applications (e.g. HPEG, Command). 

 

2. Enter a local IP address in the Local IP Address field.   

 

Note:  If you are connecting to the HOSC, and have established a VPN Client login, 

you should enter the Office Mode IP Address assigned by the VPN Client.  If you are 

connecting to a TReK training tool that is simulating the HOSC login, enter your 

computer’s local IP address.  You can use the Browse button to view and select a 

local IP Address.   

 

3. Enter the HOSC information. 

a. Enter either the HOSC Host Name or the HOSC IP Address.  

b. Enter the HOSC Port. 

 

Note:  If you are connecting to the HOSC, enter the HOSC Host Name or IP Address 

and the HOSC Port.  If you are connecting to a TReK training tool that is simulating 

the HOSC login, enter the IP Address and Port corresponding to the configuration of 

the training tool.  For example, if you are running the training tool on the same 

computer as the HOSC Login application, then you would use your local IP address 

for the Local IP Address and the HOSC IP Address. 

 

4. Push the Login button to activate the login sequence.  You will see a series of dialogs 

requesting information such as Username, Password, Passcode, Role, and Mission 

Operational Support Mode (MOP).  Enter the information requested. 

 

Note:  The Passcode is your PIN number followed by your RSA token number. 

 

If the login session is successfully activated, the Operation status will be green. 

 

5.2 How to Change Your HOSC Login Password 

The Options menu provides the capability to initiate a HOSC password change. 

 

5.3 How to Re-Authenticate your HOSC Login 

The Options menu provides the capability to initiate a HOSC login re-authentication. 
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5.4 How to Request HOSC Common Information 

The Options menu provides the capability to request HOSC Common Information.  This 

includes various types of information such as project, mission, and database information. 

 

6 Details 

This section covers various application details. 

6.1 Main Window Login Area 

The Main Window Login Area is shown in Figure 2.  Each field is described below. 

 

 

 

Figure 2 Main Window General Tab 

 

 

HOSC Login Name 

The HOSC Login Name should contain a name for the login session.  You will need this 

name when referencing the login session from other TReK Applications (e.g. HPEG, 

Command). 

 

Local IP Address 

The Local IP Address is used to perform network communication when establishing the 

login session.  If you are connecting to the HOSC, and have established a VPN Client 
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login, you should enter the Office Mode IP Address assigned by the VPN Client.  If you 

are connecting to a TReK training tool that is simulating the HOSC login, enter your 

computer’s local IP address.  You can use the Browse button to view and select a local IP 

Address.   

 

HOSC Information 

HOSC information fields include the HOSC Host Name, HOSC IP Address, and HOSC 

Port.    If you are connecting to the HOSC, enter the HOSC Host Name or IP Address and 

the HOSC Port.  If you are connecting to a TReK training tool that is simulating the 

HOSC login, enter the IP Address and Port corresponding to the configuration of the 

training tool.  For example, if you are running the training tool on the same computer as 

the HOSC Login application, then you would use your local IP address for the Local IP 

Address and the HOSC IP Address. 

 

 

6.2 Manage E-Mail and Text Settings Dialog 

The Manage E-Mail and Text Settings Dialog is shown in Figure 3.  This dialog provides 

the capability to manage global e-mail and text settings, application alert settings, e-mail 

and text dropboxes, and the capability to send an e-mail or text.   

 

 

Figure 3 Manage E-Mail and Text Settings Dialog (Global Settings Account Tab) 

 

The TReK software’s e-mail and text capability is dependent on libcurl, an open source 

client-side URL transfer library developed by the cURL project. The libcurl library 

provides C API functions that configure the library to programmatically establish a 
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secure connection with an email server using a Transport Layer Security (TLS) version 

1.3 socket prior to logging into an email account using an email account name and 

password. 

 

The TReK email and text capability has been successfully tested with the Google Gmail 

server.  It is recommended that users create a new Gmail account and use it to send 

emails and texts to designated recipients.  The TReK software does not support retrieving 

emails from the user's Gmail account.  When creating the Gmail account to send emails 

and texts you will need to configure your Gmail account to enable two-step verification 

and you need to generate a Gmail App Password for TReK.  Please reference Gmail Help 

for instructions.  The Gmail App Password is used in place of your e-mail account 

password on the Global Settings Account tab in the “Manage E-Mail and Text Settings” 

dialog.  TReK recommends only using the Gmail account to send emails and texts using 

the TReK software.  TReK does not recommend using the account to receive emails. 

 

The maximum size of a text message is approximately 900 characters.  However, if you 

send more than 900 characters your message may be broken up during transmission and 

then concatenated on the recipient’s phone.  The maximum length of a TReK email 

message is 65,000 characters or bytes.  The maximum length of an email with a file 

attachment is generally considered to be 10MB (email message size plus file attachment 

size).  Note, file attachments may become much larger than their original file sizes.  This 

is due to the encoding employed by email servers when sending non text-based 

information. 

 

Global Settings 

Global Settings are e-mail and text settings used in all TReK applications.  They can be 

changed in any TReK application with a Manage E-Mail and Text Settings dialog.  When 

you change a setting on the Global Settings tab, it will be changed for all TReK 

applications.  Each Tab is described below. 

 

Allow Alerts 

The Allow Alerts Checkbox is a global setting to turn on and off all alerts in all TReK 

applications.  If you turn this checkbox off, no alerts will be generated in any 

applications. 

 

Export  

The Export button provides access to the Export dialog shown Figure 4.  This dialog 

provides the capability to save the settings on the Global Settings tab in a TReK email 

configuration file that can be used with the TReK E-Mail and Text API.  You also have 

the option to include the dropboxes defined on the E-Mail and Text Dropboxes tab. 
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Figure 4 Manage E-Mail and Text Settings (Export Dialog) 

 

Account 

In order to use the Alerts capability, you must have a Gmail account.  The Gmail account 

must be configured with two-step verification enabled and you must have a Gmail App 

Password for TReK.  Please reference Gmail Help for instructions.  The Account tab is 

used to enter your Gmail account information.  The TReK software only stores account 

information locally.  The account password will be hidden by default and will always be 

encrypted when it is stored.  Please enter the Gmail App Password you generated for 

TReK in the E-Mail Account Password field (not your Gmail account password).  This 

password will only be decrypted when it is used communicate with the Gmail server to 

execute a requested function.  An example of account information is shown below. 

 

smtp_server_address:  smtp.gmail.com 

email_account_username: jane.doe@gmail.com 

email_account_password: Gmail App Password for TReK [Hidden unless show 

checkbox is checked] 

email_address:  jane.doe@gmail.com 

email_name:   Jane Doe 

 

The Verify Certificate Authorities checkbox is used to turn on the certificate authority 

check.  If you turn on the certificate authority check, you must provide the complete path 

to a Certificate file. 

 

The Enable Curl Debug Messages checkbox is used to turn on additional debug messages 

generated by the curl software library. 

 

 

E-Mail List 

The E-Mail List tab is used to enter e-mail addresses that will be used to populate the e-

mail address list that is available when configuring alert functions or sending an e-mail.  

The E-Mail List tab is shown in Figure 5.  The Add button is used to add a row to enter e-

mail address information.  The Delete button is used to delete a row. 
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Figure 5 Manage E-Mail and Text Settings Dialog (Global Settings E-Mail List Tab) 

 

 

Cell List 

The Cell List tab is used to enter mobile cell phone numbers that will be used to populate 

the Cell list that is available when configuring alert functions or sending a text.  The Cell 

List tab is shown in Figure 6.  The Add button is used to add a row to enter cell number 

information.  The Delete button is used to delete a row.  Cell numbers can be entered 

with or without dashes.  The Set Carrier button is available when a Cell Carrier cell is 

selected.  It is shown in Figure 7 and can be used to select a carrier address.  If the carrier 

address you need is not in the list, you can enter it directly into the cell. 
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Figure 6 Manage E-Mail and Text Settings Dialog (Global Settings Cell List Tab) 

 

 

 

Figure 7 Manage E-Mail and Text Settings (Set Carrier Dialog) 

 

Group List 

When configuring an application alert or sending an e-mail or text, you will have the 

option to identify an e-mail address, a cell phone number, or a group as a recipient.  The 
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Group List is shown in Figure 8.  You can define zero or more groups.  A group can 

contain e-mail addresses and cell numbers.  If you have a group with both e-mail 

addresses and cell numbers and you send an e-mail to that group, the e-mail generated 

will only be sent to the e-mail addresses in the group.  You can add, modify, and delete a 

group using the buttons on the right. 

 

 

Figure 8 Manage E-Mail and Text Settings Dialog (Global Settings Group List Tab) 

 

The Add button will display the Add Group dialog shown in Figure 9.  At the top you can 

enter a name for the group.  On the left you will see all the e-mail addresses and cell 

numbers you entered on the Global Settings main E-Mail List and Cell List tabs.  You 

can add zero or more e-mail addresses and zero or more cell numbers to a group.  To add 

an e-mail or cell to the group, select the e-mail or cell number on the left and push the 

Add button to add it to the group.  You can use the Delete button to delete a recipient 

from the group. 
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Figure 9 Manage E-Mail and Text Settings (Add Group Dialog) 

 

 

Application Alerts 

The Application Alerts tab is shown in Figure 10.  It is used to configure application 

specific alerts.   

 

 

Figure 10 Manage E-Mail and Text Settings Dialog (Application Alerts Tab) 

 

 

 



TREK-USER-0015 

 13 

Enable Application Alerts 

The Enable Application Alerts Checkbox is used to turn all alerts on or off in the current 

application.  If you uncheck Enable Application Alerts, no alerts will be generated in the 

Command application. 

 

Event List 

The Event area provides the capability to identify one or more alerts to send when a 

specific application event occurs.  You can add, modify, and delete alerts using the 

buttons on the right.  The Add button will display the Add Alert dialog shown in Figure 

11.   

 

 

Figure 11 Manage E-Mail and Text Settings (Add Alert Dialog) 

 

Event 

The Event is what triggers the alert.  There may be one or more events in an application 

that can trigger an alert.  The HOSC Login application can generate an alert for the 

following types of events: 

 

Lost Connection 

This event is triggered if the login connection to the HOSC is lost. 

 

Reauthentication Status 

This event is triggered when you receive a reauthentication status message from the 

HOSC. 

 

Type 

The type of alert to send.  Options are E-Mail, E-Mail and Text, or Text. 

 

Recipient 

The recipient identifies who should be notified when the event is triggered.  The 

Recipient list will be populated with applicable recipients based on Type.  If you select E-

Mail in the Type menu, the Recipient list will be populated with e-mails from the E-Mail 

List tab and groups that contain at least one e-mail address from the Group List tab.  If 

you select E-Mail and Text in the Type menu, the Recipient list will be populated with 

groups from the Group List tab that contain at least one e-mail address and one cell phone 
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number.  If you select Text in the Type menu, the Recipient list will be populated with 

cell phone numbers from the Cell List tab and groups that contain at least one cell phone 

number from the Group List tab. 

 

Additional Text 

The alert will contain the name of the event that occurred and any text that is provided in 

the Additional Text field.  Additional Text is optional. 

 

 

E-Mail and Text Dropboxes 

The E-Mail and Text Dropboxes tab is shown in Figure 12.  This tab can be used to 

define E-Mail and Text Dropboxes.  It is important to remember that each E-Mail and 

Text Dropbox will correspond to a directory on the file system and must be unique.  

Using a directory for more than one dropbox will result in unexpected behavior.  When 

you define a dropbox using the Manage E-Mail and Text Settings dialog, the dropbox 

information is automatically saved with that specific application’s settings. 

 

 

Figure 12 Manage E-Mail and Text Settings Dialog (E-Mail and Text Dropboxes Tab) 

 

Dropbox List 

The Dropbox List is used to define zero or more dropboxes.  For each dropbox you can 

define the Dropbox Type, the Dropbox Path, the Dropbox Success Path, a Recipient, and 

a State.  The buttons on the right can be used to add, modify, delete, or change the state 

of a dropbox.  The Add Dropbox dialog is shown in Figure 13. 
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Figure 13 Manage E-Mail and Text Settings (Add Dropbox Dialog) 

 

Dropbox Type 

There are three types of dropboxes: E-Mail, E-Mail File, and Text.  An E-Mail dropbox 

will e-mail the contents of a file placed in the dropbox.  An E-Mail File dropbox will e-

mail the file placed in the dropbox.  A Text dropbox will text the contents of a file placed 

in the dropbox.   

 

Dropbox Path 

The Dropbox Path identifies the local directory to be used for the dropbox.  The Browse 

button can be used to select a directory.   

 

Dropbox Success Path 

The Dropbox Success Path is optional.  If the Dropbox Success Path is defined, the 

dropbox will move the original file placed in the dropbox to the success directory if and 

only if the corresponding e-mail or text is successfully delivered to the e-mail server.  If 

the success path is empty, the dropbox will delete the original file placed in the dropbox 

if and only if the corresponding e-mail or text is successfully delivered to the e-mail 

server.  If the dropbox fails to generate the e-mail or text, the file will be renamed with a 

time tagged ".droperror" extension and remain in the dropbox.  The dropbox will not 

attempt to generate an e-mail or text for a file with a ".droperror" extension in its 

filename.  

 

Recipient 

The Recipient identifies the designated recipient(s) for the e-mail or text.  The Recipient 

list will be populated with applicable recipients based on the Dropbox Type.  For 

example, if you select E-Mail or E-Mail File in the Type menu, the Recipient list will be 

populated with e-mails from the E-Mail List Tab and groups with at least one e-mail 

address from the Group List Tab.  If you select Text in the Type menu, the Recipient list 

will be populated with cell phone numbers from the Cell List Tab and groups with at least 

one cell number from the Group List Tab. 

 

State 
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The state controls whether the dropbox is activated.  It can be set to Off or On.  If the 

state is set to Off, the dropbox will not be activated.  If the state is set to On, the dropbox 

will be activated when you push the OK button.  If the state is set to On when you exit 

the application, it will automatically be activated the next time you run the application.  If 

you do not want the dropbox to be activated on application initialization, set the state to 

Off before exiting the application. 

 

 

Send E-Mail 

The Send E-Mail tab is shown in Figure 14.  This tab can be used to send an e-mail if 

valid information has been entered on the Global Settings tab.  Once the To, Subject, 

optional File (Browse can be used to browse the local disk for a file), and Message 

information has been entered, press the Send button to send the e-mail.  This will initiate 

a request to send the e-mail.  Look at the main window message area for information 

about whether the e-mail request was successful or encountered any errors. 

 

 

Figure 14 Manage E-Mail and Text Settings Dialog (Send E-Mail Tab) 

 

Send Text 

The Send Text tab is shown in Figure 15.  This tab can be used to send a text if valid 

information has been entered on the Global Settings tab.  Once the To and Message 

information has been entered, press the Send button to send the text.  This will initiate a 

request to send the text.  Look at the main window message area for information about 

whether the text request was successful or encountered any errors. 
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Figure 15 Manage E-Mail and Text Settings Dialog (Send Text Tab) 

 

 

6.3 Advanced Settings 

The Advanced Settings dialog provides access to configure several advanced settings.  

The Advanced Settings dialog is shown in Figure 16. 

 

 

Figure 16 Advanced Settings Dialog 

 

Communication Timeout 

You can set the timeout value used in communication with the Huntsville Operations 

Support Center.   It is unlikely there would ever be a need to modify this setting.  The 

timeout value can only be modified when the Login session is inactive.   
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Log TReK ERIS Interface Messages 

The TReK HOSC Login application provides the capability to log messages that are 

exchanged between the TReK HOSC Login application and the HOSC ERIS software to 

a file.  This capability has been provided for troubleshooting purposes.  Hopefully this is 

a feature you will never need to use.  If you check the Log TReK ERIS Interface 

Messages checkbox, the messages that are exchanged between the TReK HOSC Login 

application and the HOSC ERIS software will be written to the log file specified.  

Message Logging will start when the Login Session is activated and stop if you uncheck 

the box or the Login Session is deactivated.  Once a log file exists, any new messages 

will be appended to the existing log file.  Log files are appended with the time the file 

was created as shown in the example below.  Log files older than 7 days are 

automatically deleted. 

 

Example Log File:  trek_eris_interface_message_log_2021-03-14-18-26-29.txt 

 

Log Directory  

The Log Directory field should contain the absolute path to the directory where the log 

file should be written.  

   

Log Filename 

The Log Filename field should contain the name to use for the log file. 

 

 

6.4 Application Messages 

Various types of application messages are generated including information, progress, 

warning, error, and debug messages.  Application messages are stored in memory and 

written to a temporary log file.  The temporary log file is created on application 

initialization and exists as long as the application is running.  It is deleted when you exit 

the application.  The log file is located in the temporary directory provided by the 

operating system.  Only a subset of messages are stored in memory while all messages 

are written to the temporary log file.  The maximum number of application messages 

stored in memory is controlled by the message storage setting in the Configure Messages 

dialog.  Once the maximum is reached, older messages are deleted to make room for new 

messages.  Setting the maximum value to a large number can impact application 

performance since it will increase the amount of memory used by the application.  Setting 

this number too low can cause you to miss important messages.  The application default 

was selected to protect against both of these scenarios.  Messages stored in memory are 

displayed in the Main Window Message Area and the Messages dialog.  The Messages 

dialog is shown in Figure 17.  The Main Window message area only displays Info, 

Warning, and Error messages.  The Messages dialog displays messages based on the 

display preferences defined in the Configure Messages dialog.  By default, the Messages 

dialog will display information, progress, warning, and error messages.  Columns in the 

Messages dialog can be sorted by clicking on the column header.  The Messages dialog is 

available from the Options menu.   
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Figure 17 Messages Dialog 

 

Configure 

The Configure button provides access to the Configure Messages dialog shown in Figure 

18.  This dialog provides access to preferences associated with messages.  Display 

preferences can be set to filter the types of messages (category) displayed in the 

Messages dialog.  Export Preferences control how the time tag is added to the filename 

that is created when messages are exported.  See the Export section for details.  Message 

storage defines the maximum number of messages that will be stored in memory while 

the application is running.  Once the maximum is reached, older messages are deleted to 

make room for new messages.  The Set to Defaults button can be used to reset these 

properties to application defaults. 

 

 

 

Figure 18 Configure Messages Dialog 

 

 

Clear 

The Clear button provides access to the Clear Messages dialog shown in Figure 19.  This 

dialog provides two ways to clear application messages stored in memory.  You can clear 
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all the messages or clear selected messages.  Once you clear messages, the messages are 

permanently deleted in all views (Main Window Message Area and the Messages dialog). 

 

 

Figure 19 Clear Messages Dialog 

 

 

Export 

The Export button provides the capability to save all the application messages currently 

in memory to a file.  When you push the Export button you will be prompted for a 

directory and filename.  Export will save all messages in memory, not just the messages 

currently displayed in the Messages dialog (i.e. the Display Preferences are not applied).  

The name you provide for the file will be modified with a time tag that is added to the 

filename.  The time tag indicates the time the file was closed.  The default is to append 

the time tag to the filename.  For example: 

 

Filename Input:   messages.txt 

Filename Output: messages_2017-05-07_13~03~28.txt 

 

If you would like to prepend the time tag to the filename you can set this preference in 

the Configure Messages dialog.  This would result in the following: 

 

Filename Input:   messages.txt 

Filename Output: 2017-05-07_13~03~28_messages.txt 

 

 

Delog 

The Delog button provides the capability to save all application messages generated since 

the application was started.  Delog will retrieve the messages from the temporary log file.  

When you push the Delog button you will be prompted for a directory and filename.  A 

timetag is not applied to the filename. 

 

Filename Input:   messages.txt 

Filename Output: messages.txt 
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6.5 Application Settings 

The HOSC Login application saves some settings as application settings each time you 

exit the application.  The next time you run the application, the application will initialize 

with the previous application settings.  Only one set of settings are saved.  If you run 

multiple instances of the application, the settings in the instance that is exited last will be 

saved.  The following application settings are saved: 

 

➢ Application Window Size 

➢ HOSC Login Name 

➢ HOSC Host Name or HOSC IP Address Selection 

➢ HOSC Host Name Entry 

➢ HOSC IP Address Entry 

➢ HOSC Port Entry 

➢ Configure Messages Selections 

➢ E-Mail and Text Settings 

➢ Advanced Settings 

 

7 FAQ and Troubleshooting 

This section addresses Frequently Asked Questions and provides tips for troubleshooting 

common gotchas. 

 
No FAQs Yet. 

 


